Cookies помогают нам улучшить наш веб-сайт и подбирать информацию, подходящую конкретно вам.
Используя этот веб-сайт, вы соглашаетесь с тем, что мы используем coockies. Если вы не согласны - покиньте этот веб-сайт

Подробнее о cookies можно прочитать здесь

 

MADWWW

Веб-студия (812) 317-11-73

Установка PHP-Imagic на MAC OS X под XAMPP

Установите brew

Подробнее: http://brew.sh

 

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Установите ImageMagick

brew install imagemagick

Установите php56 под brew

brew install php56

Мне brew выдал ошибку и написал список известных ему пакетов.

Error: No available formula with the name "php56" 
==> Searching for similarly named formulae...
Error: No similarly named formulae found.
==> Searching taps...
These formulae were found in taps:
homebrew/php/php56-amqp                  homebrew/php/php56-pdo-pgsql
homebrew/php/php56-apcu                  homebrew/php/php56-phalcon
homebrew/php/php56-augmentedtypes        homebrew/php/php56-pimple
homebrew/php/php56-binpack               homebrew/php/php56-pinba
homebrew/php/php56-blitz                 homebrew/php/php56-proctitle
homebrew/php/php56-boxwood               homebrew/php/php56-propro
homebrew/php/php56-chdb                  homebrew/php/php56-protobuf
homebrew/php/php56-couchbase             homebrew/php/php56-pspell
homebrew/php/php56-crypto                homebrew/php/php56-pthreads
homebrew/php/php56-dbase                 homebrew/php/php56-qr
homebrew/php/php56-dbus                  homebrew/php/php56-raphf
homebrew/php/php56-dmtx                  homebrew/php/php56-rdkafka
homebrew/php/php56-eio                   homebrew/php/php56-redis
homebrew/php/php56-ev                    homebrew/php/php56-redland
homebrew/php/php56-event                 homebrew/php/php56-riak
homebrew/php/php56-fast_assert           homebrew/php/php56-runkit
homebrew/php/php56-gearman               homebrew/php/php56-scrypt
homebrew/php/php56-geoip                 homebrew/php/php56-snappy
homebrew/php/php56-geos                  homebrew/php/php56-snmp
homebrew/php/php56-gmagick               homebrew/php/php56-sodium
homebrew/php/php56-gmp                   homebrew/php/php56-solr
homebrew/php/php56-gnupg                 homebrew/php/php56-sphinx
homebrew/php/php56-graphdat              homebrew/php/php56-spl-types
homebrew/php/php56-grpc                  homebrew/php/php56-ssh2
homebrew/php/php56-hprose                homebrew/php/php56-stats
homebrew/php/php56-htscanner             homebrew/php/php56-stemmer
homebrew/php/php56-http                  homebrew/php/php56-suhosin
homebrew/php/php56-httpparser            homebrew/php/php56-sundown
homebrew/php/php56-igbinary              homebrew/php/php56-svm
homebrew/php/php56-imagick               homebrew/php/php56-swoole
homebrew/php/php56-intl                  homebrew/php/php56-symfony-debug
homebrew/php/php56-ioncubeloader         homebrew/php/php56-thrift
homebrew/php/php56-jsmin                 homebrew/php/php56-tidy
homebrew/php/php56-kafka                 homebrew/php/php56-timecop
homebrew/php/php56-leveldb               homebrew/php/php56-timezonedb
homebrew/php/php56-libevent              homebrew/php/php56-trace
homebrew/php/php56-libsodium             homebrew/php/php56-twig
homebrew/php/php56-libvirt               homebrew/php/php56-uopz
homebrew/php/php56-lz4                   homebrew/php/php56-uploadprogress
homebrew/php/php56-lzf                   homebrew/php/php56-uuid
homebrew/php/php56-magickwand            homebrew/php/php56-v8js
homebrew/php/php56-mailparse             homebrew/php/php56-varnish
homebrew/php/php56-maxminddb             homebrew/php/php56-vld
homebrew/php/php56-mcrypt                homebrew/php/php56-wbxml
homebrew/php/php56-mecab                 homebrew/php/php56-xcache
homebrew/php/php56-memcache              homebrew/php/php56-xdebug
homebrew/php/php56-memcached             homebrew/php/php56-xhgui
homebrew/php/php56-meminfo               homebrew/php/php56-xhprof
homebrew/php/php56-midgard2              homebrew/php/php56-xmldiff
homebrew/php/php56-mongo                 homebrew/php/php56-xxtea
homebrew/php/php56-mongodb               homebrew/php/php56-yac
homebrew/php/php56-mosquitto             homebrew/php/php56-yaf
homebrew/php/php56-msgpack               homebrew/php/php56-yaml
homebrew/php/php56-mustache              homebrew/php/php56-yar
homebrew/php/php56-mysqlnd_ms            homebrew/php/php56-yaz
homebrew/php/php56-oauth                 homebrew/php/php56-yp
homebrew/php/php56-opcache               homebrew/php/php56-yrmcds
homebrew/php/php56-parsekit              homebrew/php/php56-zmq
homebrew/php/php56-pcntl                 homebrew/php/php56-zookeeper
homebrew/php/php56-pdflib                homebrew/php/php56
homebrew/php/php56-pdo-dblib
To install one of them, run (for example):
  brew install homebrew/php/php56-amqp

Используем homebrew/php/php56:

brew install homebrew/php/php56

Установите php-imagic

brew install php56-imagick

Все, что нужно мы установили

Добавьте Imagic в php.ini

Нужно добавить в php.ini строчку

extension=/usr/local/Cellar/php56-imagick/3.4.3_1/imagick.so

Ее нужно добавить в блок

;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;

/usr/local/Cellar/php56-imagick/3.4.3_1/ - этот путь у вас может отличаться в зависимости от версии.

Перезапустите Apache

Дальше в phpinfo должен появиться блок imagick

У меня этот блок не появился. PHP выдал ошибку в логе php_error_log (папка logs в xampp):

Library not loaded: /usr/local/opt/freetype/lib/libfreetype.6.dylib
  Referenced from: /usr/local/opt/imagemagick/lib/libMagickWand-7.Q16HDRI.0.dylib
  Reason: Incompatible library version: libMagickWand-7.Q16HDRI.0.dylib requires version 20.0.0 or later, but libfreetype.6.dylib provides version 15.0.0 in Unknown on line 0

В моем случае в XAMPP у меня была старая версия libfreetype.6.dylib. Нужно новую взять из brew:

Сделайте ссылку с файла libfreetype.6.dylib в папке  /Applications/XAMPP/xamppfiles/lib в папку /usr/local/Cellar/freetype/2.7.1/lib

Перезапускаем Apache - все работает.